Search Gradle plugins

Version 0.6 (latest)

Created 07 February 2019.

Yet another WsImport Gradle plugin - requires Gradle 4.0 or greater. If you're still on Gradle 3.x use version 3.0 of this plugin.

Using the plugins DSL:

plugins {
  id "uk.co.boothen.gradle.wsimport" version "0.6"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gradle.plugin.uk.co.boothen.gradle:gradle-wsimport:0.6"
  }
}

apply plugin: "uk.co.boothen.gradle.wsimport"

Using the plugins DSL:

plugins {
  id("uk.co.boothen.gradle.wsimport") version "0.6"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gradle.plugin.uk.co.boothen.gradle:gradle-wsimport:0.6")
  }
}

apply(plugin = "uk.co.boothen.gradle.wsimport")

Learn how to apply plugins to subprojects