Search Gradle plugins

Version 0.7.10 (latest)

Created 24 September 2019.

Enables libraries with CVEs to be patched in one place.

Using the plugins DSL:

plugins {
  id "io.beekeeper.gradle.plugins.security.patcher" version "0.7.10"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "io.beekeeper.gradle:beekeeper-security-plugin:0.7.10"
  }
}

apply plugin: "io.beekeeper.gradle.plugins.security.patcher"

Using the plugins DSL:

plugins {
  id("io.beekeeper.gradle.plugins.security.patcher") version "0.7.10"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("io.beekeeper.gradle:beekeeper-security-plugin:0.7.10")
  }
}

apply(plugin = "io.beekeeper.gradle.plugins.security.patcher")

Learn how to apply plugins to subprojects