Search Gradle plugins

Version 0.2.0

Created 12 December 2018.

Gradle Kotlin DSL ktlint convention plugin

Using the plugins DSL:

plugins {
  id "org.gradle.kotlin-dsl.ktlint-convention" version "0.2.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "org.gradle.kotlin:gradle-kotlin-dsl-conventions:0.2.0"
  }
}

apply plugin: "org.gradle.kotlin-dsl.ktlint-convention"

Using the plugins DSL:

plugins {
  id("org.gradle.kotlin-dsl.ktlint-convention") version "0.2.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("org.gradle.kotlin:gradle-kotlin-dsl-conventions:0.2.0")
  }
}

apply(plugin = "org.gradle.kotlin-dsl.ktlint-convention")

Learn how to apply plugins to subprojects