Search Gradle plugins

Version 0.2.0 (latest)

Created 07 December 2018.

An unofficial plugin for running `ts2kt` on NPM dependencies.

Using the plugins DSL:

plugins {
  id "net.octyl.ts2kt-unofficial" version "0.2.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gradle.plugin.net.octyl:ts2kt-unofficial-gradle-plugin-plugin:0.2.0"
  }
}

apply plugin: "net.octyl.ts2kt-unofficial"

Using the plugins DSL:

plugins {
  id("net.octyl.ts2kt-unofficial") version "0.2.0"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gradle.plugin.net.octyl:ts2kt-unofficial-gradle-plugin-plugin:0.2.0")
  }
}

apply(plugin = "net.octyl.ts2kt-unofficial")

Learn how to apply plugins to subprojects