Search Gradle plugins

fr.jcgay.gradle-jdk-chooser

A plugin that choose a JDK and configure 'release' javac argument to build your project

https://github.com/jcgay/gradle-jdk-chooser-plugin

Version 0.1.1 (latest)

Created 19 February 2020.

A plugin that choose a JDK and configure 'release' javac argument to build your project

Using the plugins DSL:

plugins {
  id "fr.jcgay.gradle-jdk-chooser" version "0.1.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "fr.jcgay.gradle-jdk-chooser-plugin:gradle-jdk-chooser-plugin:0.1.1"
  }
}

apply plugin: "fr.jcgay.gradle-jdk-chooser"

Using the plugins DSL:

plugins {
  id("fr.jcgay.gradle-jdk-chooser") version "0.1.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("fr.jcgay.gradle-jdk-chooser-plugin:gradle-jdk-chooser-plugin:0.1.1")
  }
}

apply(plugin = "fr.jcgay.gradle-jdk-chooser")

Learn how to apply plugins to subprojects