Search Gradle plugins

Version 0.1 (latest)

Created 19 July 2019.

Java dependencies compatibility plugin

Using the plugins DSL:

plugins {
  id "com.wxmlabs.java-compatibility" version "0.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "gradle.plugin.com.wxmlabs:java-compatibility-plugin:0.1-SNAPSHOT"
  }
}

apply plugin: "com.wxmlabs.java-compatibility"

Using the plugins DSL:

plugins {
  id("com.wxmlabs.java-compatibility") version "0.1"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("gradle.plugin.com.wxmlabs:java-compatibility-plugin:0.1-SNAPSHOT")
  }
}

apply(plugin = "com.wxmlabs.java-compatibility")

Learn how to apply plugins to subprojects