Search Gradle plugins

com.cognifide.aem.common

Provides AEM DSL / 'aem' extension to build script on which all other logic is based.

https://github.com/Cognifide/gradle-aem-plugin

Version 8.1.2 (latest)

Created 12 November 2019.

Provides AEM DSL / 'aem' extension to build script on which all other logic is based.

Using the plugins DSL:

plugins {
  id "com.cognifide.aem.common" version "8.1.2"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url "https://plugins.gradle.org/m2/"
    }
  }
  dependencies {
    classpath "com.cognifide.gradle:aem-plugin:8.1.2"
  }
}

apply plugin: "com.cognifide.aem.common"

Using the plugins DSL:

plugins {
  id("com.cognifide.aem.common") version "8.1.2"
}

Using legacy plugin application:

buildscript {
  repositories {
    maven {
      url = uri("https://plugins.gradle.org/m2/")
    }
  }
  dependencies {
    classpath("com.cognifide.gradle:aem-plugin:8.1.2")
  }
}

apply(plugin = "com.cognifide.aem.common")

Learn how to apply plugins to subprojects